Lag on statistics updating
Incident Report for Mailjet
Resolved
There is no more lag on your statistics, and the issue has been fixed by our technical team. If you still encounter some issues with your statistics, please contact our support team at https://www.mailjet.com/support/ticket/
Posted 19 days ago. Oct 04, 2017 - 07:54 UTC
Identified
You may be impacted by a lag on statistics updating, your emails and campaigns are being sent, but not updated on your account. Your campaigns could be displayed as “queued”, please do not re-send your campaigns as it has been sent. No data is lost and your emails are have been sent. Our engineers are already working to fix this issue and to all statistics will be up to date shortly.
If you have urgent questions about this, our customer support team is here to help. You can contact us at https://www.mailjet.com/support/ticket/
Posted 20 days ago. Oct 03, 2017 - 10:11 UTC