Slow Subscription Widget
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 11 months ago. Mar 06, 2017 - 19:09 UTC
Investigating
Some users may currently be experiencing issues with our subscription widget. Our engineers are already investigating and we will update you here shortly.
Posted 11 months ago. Mar 06, 2017 - 13:01 UTC