[Resolved] Temporary interruption in Mailjet service
Incident Report for Mailjet
Resolved
Some users may have experienced difficulties accessing Mailjet services between 16:53 UTC and 17:40 UTC. All services are now operational and messages through our SMTP server during the downtime were stored and have been sent. Should you have any questions, please contact our Support Team at mailjet.com/support/ticket.
Posted Jul 12, 2016 - 18:51 UTC