Delays in campaign processing and stats display
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 15, 2016 - 17:31 UTC
Investigating
We are currently experiencing a delay in campaign email sending and stats updating due to a high volume of traffic. No data has been lost, our IT team are working on a resolution and the system will update as soon as possible. Transactional emails are unaffected. Should you have any questions, please contact our Support Team at mailjet.com/support/ticket.
Posted about 1 year ago. Sep 15, 2016 - 16:27 UTC