Delivery issue on Microsoft destinations
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 20, 2017 - 21:48 UTC
Update
We are still actively working with the Microsoft team. The problem appears to be on the side of Microsoft, affecting Mailjet and other major email providers in Europe. Please note that you may still see some of your emails sent to Microsoft destinations (Outlook, Hotmail ect.) being rejected by their servers. Thank you again for your patience as we continue to receive more information from the Microsoft team.
Posted 3 months ago. Sep 20, 2017 - 12:54 UTC
Identified
We are currently facing a delivery issue with Microsoft destinations (inboxes such as Hotmail, Outlook etc.). This means that emails being sent to these inboxes could possibly be rejected. We are already working with the Microsoft delivery team to resolve this as fast as possible. We understand how important this is for you and please rest assured that we are working hard to have this fixed.
Posted 3 months ago. Sep 19, 2017 - 09:09 UTC