Delay in Statistics Updating
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 4 months ago. May 24, 2017 - 07:25 UTC
Investigating
We are currently experiencing a delay in stats updating due to a high volume of traffic. No data has been lost, and all emails have been sent. Our IT team are working on a resolution and the system will update as soon as possible. Should you have any questions, please contact our Support Team at mailjet.com/support/ticket.
Posted 4 months ago. May 23, 2017 - 15:53 UTC