Mailjet App Unavailable
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 16, 2017 - 11:19 UTC
Investigating
Some users may be experiencing difficulties connecting to the Mailjet app or see an “Internal Server Error” message. Emails are being sent. Our engineers are already investigating and we will update you here shortly.
Posted 7 months ago. Feb 16, 2017 - 11:01 UTC