Delay in statistics updating
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 29, 2016 - 06:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. Oct 26, 2016 - 09:02 UTC
Investigating
We are currently experiencing a delay in stats updating due to a high volume of traffic. No data has been lost, and all emails have been sent. Our IT team are working on a resolution and the system will update as soon as possible. Should you have any questions, please contact our Support Team at mailjet.com/support/ticket.
Posted 11 months ago. Oct 24, 2016 - 15:40 UTC