Delay in statistics updating
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted about 1 year ago. Oct 22, 2016 - 06:31 UTC
Identified
We are currently experiencing a delay in stats updating due to a high volume of traffic. No data has been lost, our IT team are working on a resolution and the system will update as soon as possible. Should you have any questions, please contact our Support Team at mailjet.com/support/ticket.
Posted about 1 year ago. Oct 21, 2016 - 10:29 UTC