Mailjet website outage
Incident Report for Mailjet
Resolved
Everything is back to normal, you can access again our main website https://www.mailjet.com
Posted 7 months ago. May 03, 2018 - 15:12 UTC
Investigating
You may encounter errors when accessing our marketing website, our engineers are working on that issue. In the meantime, be assured you can signin properly to your account using https://app.mailjet.com/signin
Posted 7 months ago. May 03, 2018 - 14:45 UTC