Messages experiencing delays in their delivery
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 21:44 UTC
Monitoring
We are continuing to monitor outbound mail queues and will provide the next update when outbound mail is being delivered within normal thresholds.
Posted Jun 22, 2023 - 20:57 UTC
Update
A resolution has been put in place and systems are stabilized. We are still processing outbound mail queues and customers may still see delays in outbound email.
Posted Jun 22, 2023 - 20:13 UTC
Update
The issue has been remediated and systems are beginning to process normally, but outbound mail is still delayed. Next update in one hour.
Posted Jun 22, 2023 - 19:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 22, 2023 - 17:59 UTC
Update
Engineers continue to work on the issue and are restarting services which may temporarily impact other services.
Posted Jun 22, 2023 - 16:16 UTC
Identified
Engineers have identified the issue and are continuing to work on a resolution.
Posted Jun 22, 2023 - 15:59 UTC
This incident affected: Outgoing SMTP.