we’re investigating a high number of login attempts against our application

Incident Report for Mailjet

Resolved

This incident has been resolved.
Posted Apr 28, 2020 - 15:19 UTC

Investigating

We are currently investigating this issue.
Posted Apr 28, 2020 - 15:06 UTC
This incident affected: Mailjet App.