Microsoft Incident Resulting in Delivery Issues to M365

Incident Report for Mailjet

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 12:55 UTC

Monitoring

Starting around 08:00 UTC, Microsoft began experiencing an incident causing an increased volume of deferred emails across all M365 regions. The affected responses are returning "451 4.7.500 Server busy". Our teams are actively monitoring the situation. Sending to other email providers is not affected.
Posted Sep 04, 2026 - 12:23 UTC