Inconsistent performance accessing the Email Editor
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted Feb 09, 2023 - 12:50 UTC
Identified
Our teams have detected inconsistent performance when accessing the Email Editor. This is related to a cache issue that will be automatically resolved tomorrow 2pm CEST time. We have determined that a workaround is to clear your cache or attempt to log in using a different browser. Please contact your support team if you have any further questions.
Posted Feb 08, 2023 - 16:34 UTC
This incident affected: Mailjet Embedded.