High load on app.mailjet.com
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 19, 2018 - 19:35 UTC
Monitoring
We’ve now identified and fixed the problem that caused some users to have difficulty accessing their Mailjet account. The platform can now be accessed normally and we are still monitoring our database servers to be sure everything is running smoothly.
Posted 5 months ago. Mar 19, 2018 - 16:31 UTC
Investigating
You may be having difficulties accessing your Mailjet account. Our engineers are investigating. We understand this is critical and are working to solve this urgently. We will update you here shortly.

If you have urgent questions, our customer support team is here to help. You can contact them here: https://www.mailjet.com/support/ticket/open
Posted 5 months ago. Mar 19, 2018 - 16:03 UTC