Slow email delivery
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 05, 2017 - 05:00 UTC
Identified
Some users, on shared IPs may be experiencing slow email delivery. The cause has been identified and resolved, however the queued emails will take some time to process. All emails are being processed and no data is lost. If you are experiencing issues, and are unsure of the cause, please open a ticket with our support team (https://app.mailjet.com/support/ticket). We will update you here shortly.
Posted 3 months ago. Jul 04, 2017 - 14:18 UTC