Delay in Statistics Displaying
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 17, 2017 - 18:09 UTC
Investigating
Some users are experiencing a delay in seeing their statistics. Our engineers are already investigating and we will update you here shortly. Please note that no data is lost and all information will display again once the delay is resolved.
Posted 7 months ago. Feb 16, 2017 - 14:12 UTC