Mailjet Application Unavailable
Incident Report for Mailjet
Resolved
Normal service has been resumed. Should you have any issues please open a ticket with our support team www.mailjet.com/support/ticket.
Posted 4 months ago. May 22, 2017 - 11:52 UTC
Investigating
Some users may be experiencing difficulties connecting to the Mailjet app or see a "404” message. Emails are being sent. Our engineers are already investigating and we will update you here shortly.
Posted 4 months ago. May 22, 2017 - 11:21 UTC