Slow page loading in the app
Incident Report for Mailjet
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 29, 2016 - 18:23 UTC
Investigating
You may be experiencing a delay on pages loading within the app or an error 500 message on the front office. We are investigating and normal load speeds will resume shortly.
Posted about 1 year ago. Jun 29, 2016 - 13:07 UTC