Slow loading app
Incident Report for Mailjet
Resolved
We have fixed the problem that caused some users difficulty connecting to app.mailjet.com. The platform can now be accessed normally.
Posted 11 months ago. Feb 14, 2017 - 18:01 UTC
Investigating
Some users may be experiencing a delay on pages loading within the Mailjet app or a ‘Service Temporarily Unavailable’ message. Our IT team is already investigating and we will update you here shortly.
Posted 11 months ago. Feb 14, 2017 - 15:56 UTC